Welcome to GoProFanatics.com - The Ultimate GoPro Forum
By joining our forum, you will have access to a wealth of information about GoPro cameras and accessories including answers to frequently asked questions, choosing the best settings, how to edit your footage, troubleshooting any issues and much, much more! Be a part of our amazing GoPro community.

Click Here to Sign Up

User Tag List

Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35
Like Tree3Likes

SD card error on Hero2

  1. #1
    Junior Member
    Join Date
    Dec 2011
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    SD card error on Hero2

    I just got my hero 2 in and I bought a nice sandisk extreme pro 16gb 45mbps read/write card and i put it in the camera and it just says sd error? anyone know why this is ? spent about 130 bucks onit and the card works in my other cam so i dont think its the card.

  2. #2
    AJ
    AJ is offline
    Administrator AJ's Avatar
    Join Date
    Aug 2011
    Location
    Montreal, Canada
    Posts
    2,269
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Welcome to the forum firefite.

    The only possibility I can see is that the card is formatted differently for your other camera or something like that...try reformatting your SD card and then try plugging it back into your GoPro.

    Sometimes when you use the card on a camera, there is an imposed file system used on the card so it may not work on other devices.

    Give that a shot and let us know if that fixes the problem.

    Do you have a MAC or PC?
    GoProFanatics.com Admin

    GoProFanatics Online Store is LIVE!

    BLACK FRIDAY SALE:
    Do you have 25+ posts? You're eligible for a 15% off member's only coupon code. PM me for details!

  3. #3
    Junior Member
    Join Date
    Dec 2011
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hey , I have a PC , and i formatted my card still now luck so not to sure , might just have to try a different card

  4. #4
    AJ
    AJ is offline
    Administrator AJ's Avatar
    Join Date
    Aug 2011
    Location
    Montreal, Canada
    Posts
    2,269
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    If you have access to another card, definitely try that. If it still doesn't work, try the card in another device and if the card is OK, then the camera has a problem. At that point, I would contact GoPro Support and I'm sure they will take care of you.
    GoProFanatics.com Admin

    GoProFanatics Online Store is LIVE!

    BLACK FRIDAY SALE:
    Do you have 25+ posts? You're eligible for a 15% off member's only coupon code. PM me for details!

  5. #5
    Junior Member
    Join Date
    Dec 2011
    Posts
    3
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i went and got a new card (the same one just the 8gig) and it works great and we tried other 16gigs there and they didnt work so i think its just 2 new or to fast and big for the camera or sumthing but ya no 16gig in that card would work

  6. #6
    Moderator
    Join Date
    Sep 2011
    Location
    Toronto
    Posts
    662
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Interesting discovery. I've got a 32gb class 6 and it works find...strange

  7. #7
    AJ
    AJ is offline
    Administrator AJ's Avatar
    Join Date
    Aug 2011
    Location
    Montreal, Canada
    Posts
    2,269
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    That's definitely strange. I've got a class 10 16GB card and it works. Glad you got it figured out though!
    GoProFanatics.com Admin

    GoProFanatics Online Store is LIVE!

    BLACK FRIDAY SALE:
    Do you have 25+ posts? You're eligible for a 15% off member's only coupon code. PM me for details!

  8. #8
    Ultimate GoPro Fanatic Hobby Mounts's Avatar
    Join Date
    Dec 2011
    Location
    Cornwall, UK
    Posts
    589
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I had this problem recently and it's a simple fix.

    All you need to do is format the memory card USING THE GOPRO. It is mentioned in the manual, page 25 I think.

    Don't use a computer as I first tried as this may not work.
    RickyCollier and Giráldez like this.

  9. #9
    AJ
    AJ is offline
    Administrator AJ's Avatar
    Join Date
    Aug 2011
    Location
    Montreal, Canada
    Posts
    2,269
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)
    Yeah, formatting the card using the GoPro ensures it will work, especially if you've been using the card with another device before.
    GoProFanatics.com Admin

    GoProFanatics Online Store is LIVE!

    BLACK FRIDAY SALE:
    Do you have 25+ posts? You're eligible for a 15% off member's only coupon code. PM me for details!

  10. #10
    Junior Member doo925's Avatar
    Join Date
    Jan 2012
    Posts
    19
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I ran into this same problem today after buying a 32gb class 10 card off of Ebay. 1st time I put it in the GP, it came up with card error. I went to the delete page as Boro suggested, and deleted all. The error message disappeared. I ran a quick test record and the card works fine. Again, this forum is extremely useful. Thanks guys.
    born2ski likes this.

Page 1 of 4 123 ... LastLast

Bookmarks